هشدار در خصوص احتمال حملات راه ‌دور بر سوئيچ‌ها و سيستم‌عامل NX-OS سيسکو در اثر وجود سه نقص بحرانی

1398-10-22
مدیریت انتشار

سیسکو برای سه ‫آسیب‌پذیری بحرانی که یک ابزار کلیدی مدیریت بستر شبکه و سوئیچ‌های آن را تحت‌تأثیر قرار می‌دهند، وصله منتشر کرده است. مهاجم با سوءاستفاده از این نقص‌ها می‌تواند از راه دور و بدون احرازهویت، احرازهویت نقطه‌پایانی را دور بزند و اقدامات دلخواه را با امتیازات مدیریتی بر روی دستگاه‌های هدف اجرا کند.
این سه نقص که با شناسه‌های CVE-2019-15975، CVE-2019-15976 و CVE-2019-15977 ردیابی می‌شوند، مدیر شبکه‌ی مرکز داده‌های سیسکو (DCNM) را تحت تأثیر قرار می‌دهند. DCNM بستری برای مدیریت مراکز داده‌ی سیسکو است که بر روی NX-OS سیسکو اجرا می‌شود. NX-OS یک سیستم‌عامل شبکه است که توسط سوئیچ‌های اترنت سری‌های Nexus سیسکو و سوئیچ‌های شبکه‌‌ی بخش ذخیره‌سازی Fibre Channel سری‌های MDS، استفاده می‌شود.
محصولاتی که تحت‌تأثیر این آسیب‌پذیری‌ها قرار گرفته‌اند عبارتند از نسخه‌های نرم‌افزاری DCNM پیش از نسخه‌ی 11.3(1) در سیستم‌عامل‌های مایکروسافت ویندوز، لینوکس و ابزار مجازی.
دو نقص CVE-2019-15975 و CVE-2019-15976، آسیب‌پذیری‌های دورزدن احرازهویت در نقطه‌پایانی‌های REST API و SOAP API نرم‌افزار DCNM هستند. این آسیب‌پذیری‌ها ناشی از وجود یک کلید رمزنگاری ثابت هستند که بین نصب‌ها به اشتراک گذاشته شد‌ه‌اند. REST یک حالت معماری برای طراحی برنامه‌های کاربردی شبکه‌ای است. پروتکل دسترسی به شئ ساده (SOAP) یک سیستم پروتکلی استاندارد است که به فرایندها اجازه می‌دهد بااستفاده از سیستم‌عامل‌های مختلفی همچون لینوکس و ویندوز، از طریق HTTP و XML آن، ارتباط برقرار کنند. یک مهاجم احرازهویت‌نشده‌ی راه دور می‌تواند با ارسال یک درخواست ساختگی خاص حاوی یک نشانه‌ی (token) نشست معتبر که بااستفاده از کلید رمزنگاری ثابت تولید شده است از طریق REST API یا SOAP API، امتیازات مدیریتی به‌دست آورد و اقداماتی انجام دهد.
نقص سوم (CVE-2019-15976)، یک آسیب‌پذیری دورزدن احرازهویت مدیر شبکه‌ی مرکز داده است. این نقص در واسط مدیریتی مبتنی بر وب DCNM وجود دارد و به یک مهاجم راه‌دور احرازهویت‌نشده اجازه می‌دهد احرازهویت را در دستگاه متأثر دور بزند. این آسیب‌پذیری ناشی از وجود اعتبارنامه‌های ثابت در واسط کاربری تحت وب است. مهاجم می‌تواند بااستفاده از اعتبارنامه‌های ثابت برای تأیید اعتبار برابر واسط کاربری، از این آسیب‌پذیری سوءاستفاده کند. سوءاستفاده‌ی موفق از این آسیب‌پذیری به مهاجم اجازه می‌دهد به بخش خاصی از واسط وب دست یابد و اطلاعات اعتبارنامه‌های خاص را از دستگاه متأثر به‌دست آورد. این اطلاعات می‌تواند برای انجام حملات بیشتر علیه سیستم نیز استفاده شود.
هر سه‌ی این آسیب‌پذیری‌ها دارای امتیاز CVSS مشترک 9.8 هستند. سیسکو این آسیب‌پذیری‌ها را در نسخه‌های 11.3(1) DCNM و نسخه‌های پس از آن وصله کرده است و از لینک https://software.cisco.com/download/home/281722751/type/282088134/release/11.3(1) می‌توان آن را دریافت کرد. همچنین این شرکت بیان کرد که هیچ راه‌حلی جهت رفع این مشکلات وجود ندارد.
به کاربران توصیه می‌شود DCNM خود را همین حالا وصله کنند و اگر وصله‌کردن برایشان میسر نیست، آن را از سیستم خود حذف کنند.

منبع:

مرکز ماهر

ارتباط با ما

07154372274
apa@jahrom.ac.ir
apa.jahrom.ac.ir
استان فارس، جهرم، دانشگاه جهرم

آماز بازدید

  • بازدید فعال 14
  • بازدید امروز 14
  • بازدید کل 50962
  • نشانی شما 3.219.31.204

مراکز همکار

مرکز امداد رایانه ای سازمان فناوری اطلاعات ایران سازمان پدافند غیرعامل